atop 2.x compatiblity with current sunxi linux kernels

As usual there there plenty of updated kernels available at: https://dl.danand.de/cubieboard/experiments/

Quite interesting is the latest set, which works fine with atop 2.2.x ( atopacctd to be exact). If you plan to upgrade to Ubuntu Zesty and you currently use atop, please update your kernel to one of the following packages or ensure that CONFIG_BSD_PROCESS_ACCT is activated:

# sudo gzip -dc /proc/config.gz |grep CONFIG_BSD_PROCESS_ACCT
 CONFIG_BSD_PROCESS_ACCT=y
 CONFIG_BSD_PROCESS_ACCT_V3=y

It’s activated and tested in:

4.4.69-a:
https://dl.danand.de/cubieboard/experiments/4.4.69-a.tgz

4.9.29-a:
https://dl.danand.de/cubieboard/experiments/4.9.29-a.tgz

4.10.17-a:
https://dl.danand.de/cubieboard/experiments/4.10.17-a.tgz

4.11.2-a:
https://dl.danand.de/cubieboard/experiments/4.11.2-a.tgz

4.12-Release-Candidate2-a:
https://dl.danand.de/cubieboard/experiments/4.12-rc2-a.tgz

They all run sucessfully on my Cubieboard A20, Cubietruck A20 and Banana PI A20

 

Leave a Reply

Your email address will not be published. Required fields are marked *

Protected with IP Blacklist CloudIP Blacklist Cloud